
 

 

SCOPIA IBM Lotus Notes Add-on Deployment Guide 
 
The SCOPIA IBM Lotus Notes Add-on is a separately deployed plug-in that can work an in iVIEW 
Suite deployment or a SCOPIA Desktop deployment without iVIEW Suite. 
 
In an iVIEW Suite deployment, the SCOPIA IBM Lotus Notes Add-on allows users to schedule 
modify, cancel, and manage iCM meetings using the IBM Lotus Notes interface. 
 
In an SCOPIA Desktop deployment, the SCOPIA IBM Lotus Notes Add-on allows users to send out 
meeting invitations using the IBM Lotus Notes interface. 
 
Prerequisite 
 
The iCM IBM Lotus Notes Add-on requires the following: 
- Lotus Domino Server 

 Supported versions: 7.0 ,8.0 and 8.5 
 IBM Lotus Domino server must run DIIOP HTTP services 
 IBM Lotus Domino server must be configured as Web SSO server with Ltpa token. 
 Lotus Domino Administrator, Designer interface must be available. 

- Each user should have a dedicated e-mail account for receiving meeting messages including 
meeting accept and decline messages. 

- For iVIEW Deployment 
 A dedicated iVIEW Suite server which the SCOPIA IBM Lotus Notes add-on can connect 

to。 

 This iVIEW Suite server should be configured to work with IBM Domino Directory server.  
 In order to use the SCOPIA IBM Lotus Notes add-on, a user must have at least one virtual 

room assigned by the administrator. 
- For SCOPIA Desktop Deployment 

 A dedicated SCOPIA Desktop server which the SCOPIA IBM Lotus Notes add-on can 
connect to. 

 
What’s included? 
 
- Setup85.nsf contains the agents used to install or upgrade iCM IBM Lotus Notes Add-on 
- There are nine “.dxl” files which contain the code used to install iCM IBM Lotus Notes 

Add-on. 
 
Installation 
 
Follow the steps below to install SCOPIA IBM Lotus Notes add-in. 
 
Procedure: 
- Open Domino Designer interface to connect to the target Domino server and login using 



 

 

LocalDomainAdmins account. 
- Open setup85.nsf locally. 
- Select the 3 agents contained inside setup85.nsf and sign them. They are: 

 IVConfig.nsf which contains the configuration screen of SCOPIA IBM Lotus Notes 
Add-on 

 Mail85_IV.ntf which is based on mail85.ntf is the new template file that end user 
will use to schedule meetings using SCOPIA IBM Lotus Notes Add-on. 

 Import all Dxl to Current DB 

 

- Create IVConfig.nsf remotely 
 Select IVConfig.nsf agent and select the “Run” option. 
 In the “DXL Import” window that opens, select IVConfig.dxl that is in the same 

directory as this document. 
 The agent completes the operation and IVConfig.nsf is created remotely. 

- Create mail85_IV.ntf remotely. 
 Select mail85_IV.ntf agent and select the “Run” option. 
 In the “DXL Import” window that opens, select IVAgentLib.dxl that is in the same 

directory as this document. 
 The agent completes the operation and mail85_IV.ntf is created remotely. 

- Close Domino Designer interface. 
 
- Open Domino Administrator interface and connect to the target Domino server. 
- Under the File tab, select properties window of mail85_IV.ntf template. 
- In the Database properties popup window 

 Check “Database file is master template” field. 
 In the “Template Name” field, select StdMail85_IV. 
 Close the Database properties popup window. 

- Save the settings and close Domino Administrator interface. 
 



 

 

 
 
- Open Domino Designer interface to connect to the target Domino server and login using 

LocalDomainAdmins account. 
- Go to “File > Database > Open” to open “Open Database” window. 

 In the “Server” select list, chose the remote Domino server that has SCOPIA IBM 
Lotus Notes add-on installed. 

 In the “Database” list that displays all the databases on that server, select “Mail 
(R8.5) IV Addon” database and open it. 

- Insert code into _Calendar Entry Form 
 In “Mail (R8.5) IV Addon” database, go to “Top Menu > View > Go to > Forms” to 

display all the forms in this database. 
 Select “_Calender Entry” and double click to open “_Calendar Entry Form”. 
 Find the “Body” field and add a new line just above this field. From menu 

“Create”->”Resource”-> “Insert subform” 



 

 

  

 
 In the “Insert Subform” popup window:  

 select “IVSubForm” entry. 
 Click “OK” button to close the window. 
 You can see that subform is inserted just above “Body” field. 

 Close the “_Calendar Entry Form” and save the changes. 
- Insert code into ($Calendar) View 

 In “Mail (R8.5) IV Addon” database, go to “Top Menu > View > Go to > Views” to 
display all the views in this database. 

 Select ($Calendar) and double click to open it. 
 Make sure “View > Action Pane” option is checked. 
 In the “Action Pane” frame, find “Unfilter” entry. Open its popup menu and select 

“Create Action …” 



 

 

 

 In the “Action” popup window, enter “SCOPIA Settings” in the Name field. 

 
 In the second tab of the “Action” window, select “Hide action if formula is true”  
 Click “Formula Window” button to open “Edit Formula” window. 
 Paste the following code in the “Edit Formula” window: 

@If(@TextToNumber(@Version) < 174;@True;@False) | @Environment("OEMClient") 
= "1" | @IsNotMember("Notes_Video_conf_sched_group"; @UserNamesList) 



 

 

 
 Close the “Action” window. 
 In the “(Action): Click” window, add the following code: 

@If(@ClientType = "Notes";@Command([Compose];"IVClientConfig") : 
@Return(0);"") 

 
- Insert code into _Calendar Entry Form 

 In “Mail (R8.5) IV Addon” database, go to “Top Menu > View > Go to > Forms” to 
display all the forms in this database. 

 Select “_Calender Entry” and double click to open “_Calendar Entry Form”. 
 Make sure “View > Programmer’s Pane” option is checked. 
 In the “Objects” tab, select “(Global) Appointment > (Options)” entry. Add the 

following line to the code: 
Use "IVShareLib" 

 
 In the “Object” tab, select “Appointment (Form) > Queryopen”. In the code, look 



 

 

for “CSCalendarEntry” and replace it with “IVCSWrapper” 

 
 Save the form and close it. 

- Insert Code into CSUIViewClass Script Library 
 In “Mail (R8.5) IV Addon” database, go to “Top Menu > View > Go to > Script 

Libraries” to display all the forms in this database.        
 Select “CSUIVClass” and double click to open “CSUIVClass – Script Library”. 
 In “Objects” tab, select “CSUIVClass > (Options)”. Add the following code: 

Use "IVShareLib" 

  
 In “Objects” tab, select “CSUIVClass > InitEventObject”. In the code, look for 

“CSEventNotes” and replace it with “IVCalendarWrapper”. 

 
 Save changes and close the script library. 



 

 

 
Configuration 
 

Use New Template 
Create a user group called “Notes_Video_conf_sched_group”. 
Any user that you assign to this group will be able to see the user interface of the SCOPIA 
IBM Lotus Notes Add-on. 
 
Use Domino server console command to change mail file template for all affected users. 
For example, assume user John’s mail file is John.nsf in mail directory, send the following 
command from the Domino Server Console to convert template of John.nsf to mail7.ntf 
>> load convert mail\ John.nsf * mail85_IV.ntf (for Windows)                         
>> load convert mail/ John.nsf * mail85_IV.ntf (for Linux)                        
To change all the mail files in mail directory, send the following command: 
>> load convert mail\*.nsf * mail85_IV.ntf  (for Windows)                       
>> load convert mail/ *.nsf * mail85_IV.ntf (for Linux) 

Domino Web SSO Configuration 
- Open Domino Administrator interface to connect to the target Domino server. 
- Open the “Configuration” tab and select “Server > Current Server Document”.  
- Click ‘Create Web” icon and select “SSO Configuration” option. 

 

- In the “Web SSO Configuration” window 
 Enter the iVIEW Suite server DNS domain in the “DNS Domain” field such as 

“mycompany.com”. 
 Make sure the Domino server with SCOPIA IBM Lotus Notes Add-on installed is 

configured in “Domino Server Names” field such as “Domino3/Test”. 
 Click on “Key …” icon and select “Create Domino SSO Key” option to generate a 

new key. 



 

 

 

 Save changes and close the “Web SSO Configuration” window. 
- Under “Server > Current Server Document” 

 Select “Internet Protocols … > Domino Web Engine” tab. Click the “Edit” icon to 
make change. 
 Set Session authorization field to “Multiple Servers (SSO)”. 
 Set Web SSO Configuration field to “LtpaToken”. 

 
 Select “Basics” tab and make sure Load Internet configurations from 

Server\Internet Sites documents field is “Disabled”. 



 

 

 
- Click “Save & Close” icon to save changes 
 
Note: This Web SSO configuration is R5 compatible. 
 

Assign ECL 
You need to assign ECL to users so that they can execute the client side module of SCOPIA 
IBM Lotus Notes Add-on. 
You should create a new policy which allows users run the SCOPIA IBM Lotus Notes Add-on, 
and then assign this policy to user group “Notes_Video_conf_sched_group”. 
 
Procedure: 
- Open Domino Administrator interface to connect to the target Domino server. 
- Open the “Configuration” tab and select “Policies”. Click “Create” to create a new policy. 

 
- Give the new policy a name such as “IV_POLICY” in “Basics” tab. 
- In the “Security” field, click “New …” button to create a new security settings. 



 

 

 
- Give the new security setting a name such as “IV_SECURITY” in “Basics” tab. 

 
- In “Execution Control List” tab,  

 Set Update Mode to “Replace”. 
 Create a new “Admin ECL” such as “IV_ECL”. 

 
- In the Execution Control List popup window, define the “Workstation Security” for the 

domain admin user such as “admin/Test”. Check the access options according to the 
figure below. 



 

 

 

- In the Execution Control List popup window, define the “Java applet Security” for the 
domain admin user such as “admin/Test”. Check the access options according to the 
figure below. 

-  

 
- Save change and close the policy window 
 
- Go to “People & Groups” tab and select “Groups” entry. 
- Select “Notes_Video_conf_sched_group” entry and choose “Assign Policy …” 



 

 

 
- In the “Assign Policy Options” window, select “IV_POLICY” for this user group. 
- Click OK to close the window and save changes. 
 

SCOPIA Administrator Settings 
Please follow the steps below to make the server side configuration for SCOPIA IBM Lotus 
Notes add-on using SCOPIA Administrator Settings window. 
 
Procedure 
- Open Lotus Notes interface and go to “File > Database > Open” to open the “Open 

Database” window. 
 In the “Server” select list, chose the remote Domino server that has SCOPIA IBM 

Lotus Notes add-on installed. 
 In the “Database” list that displays all the databases on that server, select “ivconfig” 

database and open it. 
- The “SCOPIA Administrator Settings” window should be opened. You can configure the 

iVIEW Suite or SCOPIA Desktop servers that end users can connect to in order to 
schedule meetings. The list of servers configured in this window will be seen by end users 
in their configuration screen. 
 In the “Add Server” section 

 Set the type of server URL that you want to add in the Server Type field. 
 Give a name to the server that you want to add in the Server Name field. 
 Provide the server URL in the Server URL field. The format should be 

http://SERVER_URL:PORT_NUMBER 
 Click “Add to List” button to add this new server to the “Server List” 

 In the “Select List” section 
 You can remove any defined server from the list using “Remove from List” 

button. 
 You can check whether the server is reachable using the “Check Server Status” 

button. The server status is displayed in the Status field. A server must be 
reachable in order for SCOPIA IBM Lotus Notes add-on to function properly. 

 In the “Advanced” section. 
 You can check whether secure communication mechanism has been properly 

configured between Lotus Domino server and iVIEW Suite server working in 
Single Sign-on (SSO) mode. 

 In order to check, click on “Generate Ltpa token” to see if a new Ltpa token is 

http://SERVER_URL:PORT_NUMBER�


 

 

displayed in the Status field. If so, that means secure communication has been 
properly configured between Lotus Domino server and iVIEW Suite server. 
Note: Ltpa token is needed to ensure secure communication between Domino 
and a third party web application. 

 

Uninstall 
 
Follow the steps below to uninstall the SCOPIA IBM Lotus Notes Add-on. 
 
Procedure: 
- Revert back to the default mail template: 

Use Domino server console command to change mail file template for all affected users. 
For example, assume user John’s mail file is John.nsf in mail directory, send the following 
command from the Domino Server Console to convert template of John.nsf to mail7.ntf 
>> load convert mail\ John.nsf * mail85.ntf (for Windows) 
>> load convert mail/ John.nsf * mail85.ntf (for Linux) 
To change all the mail files in mail directory, send the following command: 
>> load convert mail\*.nsf * mail85.ntf (for Windows) 
>> load convert mail/ *.nsf * mail85.ntf (for Linux) 
                   

- Remove ivconfig.nsf 
 Open the Domino server using Domino Administrator interface. 
 Go to Files tab and look for “ivconfig” database. 
 Select “ivconfig” database and choose the “Delete Database” option. 
 In the “Confirm Database Delete” window that pops open, select “Also delete 

replicas of this database on all other server” option. 
 Click “OK” button to delete this database. 

- Remove mail85_IV.ntf 
 In the File tab, look for “Mail (R8.5) IV Addon” template. 
 Select “Mail (R8.5) IV Add-on” template and choose the “Delete Database” option. 
 In the “Confirm Database Delete” window that pops open, select “Also delete 

replicas of this database on all other server” option. 
 Click “OK” button to delete this template. 
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