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1 About the SCOPIA IBM Lotus Notes Add-on

The SCOPIA IBM Lotus Notes Add-on is a separately deployed plug-in that can work in a 
iVIEW SCOPIA Management Suite deployment or in a standalone SCOPIA Desktop deployment 
without iVIEW SCOPIA Management Suite.

In an iVIEW SCOPIA Management Suite deployment, the IBM Lotus Notes Add-on allows users to 
schedule, modify, cancel and manage iCM meetings using the IBM Lotus Notes interface. In a 
standalone SCOPIA Desktop deployment, the SCOPIA IBM Lotus Notes Add-on allows users to send 
out meeting invitations using the IBM Lotus Notes interface. 

This documentation is for users of iVIEW SCOPIA Management Suite version 7.5, which supports 
Lotus Domino Server versions 7.0, 8.0, 8.5 and 8.5.1.

Contact your system administrator for installation information.
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About the Lotus Domino Interface

This document uses the Lotus Domino 8 interface to illustrate procedures. There are several minor 
differences between the user interfaces for each of the supported Lotus Domino versions, 
including the following:

• Version 7.0 includes a File > Database option. This is replaced in version 8 by File > 
Application. 

• Version 7 includes a Server list in the Open Database dialog box. This is replaced in version 8 
by the Look in option.
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Meeting the System Requirements

The following prerequisites are required for successful installation and operation of the IBM Lotus 
Notes Add-on:

• Lotus Domino Server 

– Supported versions: 7.0, 8.0, 8.5, and 8.5.1.

– Running DIIOP HTTP services 

– Configured with LTPA token 

– Lotus Domino Administrator and Designer interfaces must be available 

Each user should have a dedicated email account for receiving meeting messages including 
meeting accept and decline messages. 

iVIEW Suite deployments require:

• A dedicated iVIEW Suite server which the IBM Lotus Notes Add-on can connect to. 

• This iVIEW Suite server should be configured to work with IBM Domino server LDAP Directory 
service. 

• Assign at least one virtual room to each user. 

SCOPIA Desktop deployments require:

• A dedicated SCOPIA Desktop server which the IBM Lotus Notes Add-on can connect to.

These required installation files should be copied to your computer in a location of your choice:

• Setup0.nsf (where 0 represents the version number of your Lotus Domino Server) containing 
the agents used to install or upgrade SCOPIA IBM Lotus Notes Add-on. 

• Nine .dxl files containing the code used to install SCOPIA IBM Lotus Notes Add-on.

– IVAgentLib.dxl 

– IVClientConfig.dxl 

– IVConfig.dxl 

– IVForm.dxl 

– IVShareLib.dxl 

– IVSubForm.dxl 

– LotusAddonAppletJar.dxl 

– MeetingAgent.dxl 

– SDAccessAgent.dxl 
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Verifying DIIOP and HTTPS Services are Running

Procedure

Step 1 Use a text editing application to open the notes.ini file located at C:\Program 
Files\IBM\Lotus\Domino\ on your computer.

Step 2 Locate the following line:

ServerTasks=Update,Replica,Router,AMgr,AdminP,CalConn,Sched,LDAP,RnRMgr,DIIOP,HTTP 

Step 3 Verify that DIIOP and HTTP are present. Add them if they are not.

Step 4 Restart your Domino server. 

Step 5 Select Start > Programs > Lotus Applications > Lotus Domino Administrator. 

Step 6 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator. 

Step 7 Select the Domain tab displaying the name of your Lotus Domino server. 

Step 8 Select the Server tab. 

Step 9 Select the Status tab. 

Step 10 Select Server Tasks from the list below the Status tab. 

Step 11 Verify that the DIIOP Server and HTTP Server tasks appear. 

Figure 1-1  Verifying DIIOP and HTTP Services
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Installing the SCOPIA IBM Lotus Notes Add-on

• Creating NSF Objects in the Domino Designer Interface..................................  page 4 

• Creating a Template in the Domino Admin Interface......................................  page 6 

• Creating Forms and Script Libraries in the Domino Admin Interface ...................  page 7 

Creating NSF Objects in the Domino Designer Interface

This procedure uses the following terms where 0 represents the version number of your Lotus 
Domino Server: 

• mail0.ntf 

• mail0_IV.ntf 

Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Designer to connect to the target 
Domino server.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select File > Application > Open in the Lotus Domino Designer interface.

Step 4 Browse to the setup.nsf file and select Open. 

Step 5 Select the setup icon in the left panel to expand it. 
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Step 6 Select Shared Code > Agents.

Figure 1-2  Lotus Domino Designer Agents

Step 7 Sign the agents as follows:

a. Select the Create IVConfig.nsf agent in the panel on the right, and then select the Sign 
button. 

Create IVConfig.nsf contains the SCOPIA IBM Lotus Notes Add-on configuration screen. 

b. Select the Create mail0_IV.ntf agent in the panel on the right, and then select the Sign 
button. 

Create mail0_IV.ntf contains a new template file for scheduling meetings using the SCOPIA IBM 
Lotus Notes Add-on, based on mail0.ntf. 

c. Create the IVConfig.nsf file on the Domino server as follows: 

Step 8 Right-click the Create IVConfig.nsf agent and select Run.

Step 9 Select File > Application > Open and browse to the IVConfig.dxl file. 

Step 10 Select Open. 

Step 11 Create the mail0_IV.ntf file on the remote server as follows:

a. Right-click the Create mail0_IV.ntf agent and select Run. 

b. Select File > Application > Open and browse to the IVAgentLib.dxl file. 

c. Select Open. 

Step 12 Close the Domino Designer interface. 
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Creating a Template in the Domino Admin Interface

This procedure uses the following terms where 0 represents the version number of your Lotus 
Domino Server: 

• mail0_IV.ntf

• Stdmail0_IV 

Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select the Domain tab displaying the name of your Lotus Domino server.

Step 4 Select the Files tab.

Step 5 Select All file types in the Show me field. 

Step 6 Locate the mail0_IV.ntf file in the filename list. 

Step 7 Right-click mail0_IV.ntf and select Properties to display the Database dialog box.

Figure 1-3  mail0_IV_ntf File Properties

Step 8 Select the Design tab (the fourth tab from the left).

Step 9 Select Database file is master template.
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Step 10 Enter StdMail0_IV in the Template Name field. 

Step 11 Close the Database dialog box.

Step 12 Save your changes. 

Step 13 Close the Domino Administrator interface.

Creating Forms and Script Libraries in the Domino Admin Interface

This procedure uses the following terms where 0 represents the version number of your Lotus 
Domino Server: 

• Mail (R0) IV

Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select File > Application > Open in the Lotus Domino Designer interface.

Step 4 Select the Look in drop-down list.

Step 5 Select the remote Domino server that has the SCOPIA IBM Lotus Notes Add-on installed from the 
list. 
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Step 6 Select Mail (R0) IV Addon from the database list, and then select Open. 

Figure 1-4  Selecting the Remote Server

Step 7 Double-click _Calender Entry in the list of forms that displays.

Step 8 Scroll to the end of the code that appears above the list of forms and locate the Body field.

Figure 1-5  Calendar Entry Form List

Step 9 Place your cursor next to the Body field and then select Create > Resource > Insert Subform from 
the menu at the top of the screen.

Step 10 Select IVSubForm from the Insert Subform window.
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Step 11 Select OK and verify that the subform is inserted near the Body field. 

Figure 1-6  Selecting the IVSubForm

Step 12 Select the X in the _Calendar Entry Form tab to save and close the _Calendar Entry form.

Step 13 Select View > Go to > Views from the menu at the top of the screen to display all views in the 
Mail (R0) IV Addon database. 

Step 14 Double-click ($Calendar). 

Step 15 Select View again from the menu at the top of the screen and verify that Action Pane is selected. 

Step 16 Locate the Action pane at the right of the screen. 

Step 17 Right-click Unfilter and select Create Action.

Figure 1-7  Action Pane

Step 18 Enter SCOPIA Settings in the Name field in the first tab of the Actions dialog box.

Step 19 Select Hide action if formula is true in the second tab of the Action dialog box, and select Formula 
Window. 

Step 20 Paste the following code in the Edit Formula window: 

@If(@TextToNumber(@Version) < 174;@True;@False) | 

@Environment("OEMClient") = "1" | 

@IsNotMember("Notes_Video_conf_sched_group"; 

@UserNamesList) 

Step 21 Select Done to close the Action window.
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Step 22 Paste the following code in the (Action): Select window:

@If(@ClientType =

"Notes";@Command([Compose];"IVClientConfig") :

@Return(0);"") 

Step 23 Select the Mail (R0) IV Addon tab.

Step 24 Select View > Go to > Forms from the menu at the top of the screen. 

Step 25 Double-click _Calender Entry in the list of forms that displays. 

Step 26 Select View again from the menu at the top of the screen and verify that Programmer’s Pane is 
selected.

Step 27 Select (Globals)Appointment > (Options) in the Objects tab and add the following line at the end 
of the code: 

Use "IVShareLib"

Figure 1-8  Global Appointment Object

Step 28 Select Appointment (Form) > Queryopen in the Objects tab. 
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Step 29 Locate CSCalendarEntry in the code and replace with IVCSWrapper. 

Figure 1-9  CSCalendarEntry in Code

Step 30 Save and close the form. 

Step 31 Enter code into the CSUIViewAeDSClass Script Library as follows: 

a. Select the Mail (R0) IV Addon tab. 

b. Select View > Go to > Script Libraries from the menu at the top of the screen to display all 
script libraries for the Mail (R0) IV Addon database. 

c. Double-click CSUIViewAeDSClass.

d. Select CSUIViewAeDS > (Options) in the Objects tab and add the following line at the end of 
the code: 

Use "IVShareLib" 

e. Select CSUIViewAeDS > InitEventObject in the Objects tab.

f. Select CSUIViewAeDS > InitEventObject in the Objects tab. 

g. Save and close the script library. 

Configuring the SCOPIA IBM Lotus Notes Add-on

• Using a New Template......................................................................... page 12

• Configuring Domino Web Single Sign-on .................................................... page 13 

• Accessing an Execution Control List......................................................... page 14
      About the SCOPIA IBM Lotus Notes Add-on | 11RADVISION | Deployment Guide for SCOPIA IBM Lotus Notes Add-on Version 7.5



 

 

Using a New Template

This procedure uses the following terms where 0 represents the version number of your Lotus 
Domino Server: 

• mail0_IV.ntf

Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select the Domain tab displaying the name of your Lotus Domino server.

Step 4 Select the People & Groups tab, and then select Add Group.

Step 5 Create a user group called Notes_Video_conf_sched_group. 

Any user that you assign to this group can see the user interface of the SCOPIA IBM Lotus Notes 
Add-on. 

Step 6 Access the Domino server console as follows:

a. Select Start > Programs > Lotus Applications > Lotus Domino Administrator. 

b. Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator. 

c. Select the Domain tab displaying the name of your Lotus Domino server. 

d. Select the Server tab. 

e. Select the Status tab. 

f. Select Server Console from the list below the Status tab. 

Step 7 Use the Domino server console command to change the mail file template for all affected users.

For example, assume user John’s mail file is John.nsf. Enter the following command in the 
Domino Command field to convert the John.nsf template to mail0_IV.ntf:

For Windows: >> load convert mail\ John.nsf * mail0_IV.ntf 

For Linux: >> load convert mail/ John.nsf * mail0_IV.ntf 

Step 8 To change all mail files in the mail directory, send the following command: 

For Windows: >> load convert mail\*.nsf * mail0_IV.ntf 

For Linux:  >> load convert mail/ *.nsf * mail0_IV.ntf 
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Configuring Domino Web Single Sign-on

The Web Single Sign-on (SSO) configuration described here is R5 compatible.

Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select the Domain tab displaying the name of your Lotus Domino server.

Step 4 Select the Configuration tab.

Step 5 Select Server > Current Server Document. 

Step 6 Select Create Web and then SSO Configuration.

Figure 1-10  SSO Configuration
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Step 7 Enter the iVIEW Suite server DNS domain in the DNS Domain field.

For example, “mycompany.com”.

Step 8 Select the arrow next to the Domino Server Names field to display the Select Name dialog box.

Step 9 Select the name of the Domino server with the SCOPIA IBM Lotus Notes Add-on installed from the 
list in the left panel, and move it to the Names list in the right panel.

Step 10 Select OK to close the Select Name dialog box. 

Step 11 Verify that the name of the Domino server with the SCOPIA IBM Lotus Notes Add-on installed 
appears in the Domino Server Names field.

Step 12 Select Keys > Create Domino SSO Key to generate a new key.

Step 13 Select Save & Close to save your changes and close the Web SSO Configuration window. 

Step 14 Select the Configuration tab.

Step 15 Select Server > Current Server Document. 

Step 16 Select Internet Protocols > Domino Web Engine.

Step 17 Select Edit Server. 

Step 18 Select Multiple Servers (SSO) in the Session authorization option. 

Step 19 Select LtpaToken in the Set Web SSO Configuration option. 

Step 20 Select Basics and verify that the Load Internet configurations from Server\Internet Sites 
documents field is set to Disabled.

Step 21 Select Save & Close to save your changes. 

Accessing an Execution Control List

Assign an Execution Control List (ECL) to users so that they can execute the SCOPIA IBM Lotus 
Notes Add-on client-side module.

Create a new policy which allows users to run the SCOPIA IBM Lotus Notes Add-on, and then assign 
this policy to user group Notes_Video_conf_sched_group.

Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select the Domain tab displaying the name of your Lotus Domino server.

Step 4 Select the Configuration tab.
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Step 5 Select Policies > Create in the right panel to create a new policy. 

Figure 1-11  Create Policies

Step 6 Select the Policy option in the Create New Policy dialog box and select OK.

Step 7 Select Basics and enter a name for the policy in the Policy name field such as “IV_POLICY”.

Step 8 Select New next to the Security field to create new security settings.

Step 9 Enter a name for the new security setting in the Basics tab such as “IV_SECURITY”.

Step 10 Select Execution Control List. 

Step 11 Select Refresh in the Set Update Mode field.

Step 12 Select Manage next to Admin ECL and enter a name for the ECL in the Create New Admin ECL field 
such as “IV_ECL”.

Step 13 Select OK and then Edit.

Step 14 Select Allow user to modify and Workstation security in the Workstation Security: Execution 
Control List dialog box.

Step 15 Select Add and then select the icon in the Add User dialog box to specify the users that have 
permission to modify workstation security.

Step 16 Select Java applet security in the Workstation Security: Execution Control List dialog box and 
repeat 15. 
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Step 17 Select the following access options:

• Access to file system 

• Access to Notes Java classes 

• Access to network addresses 

• Printing 

• Access to system properties 

• Dialog and clipboard access 

• Process-level access 

Step 18 Select Edit Server. 

Step 19 Select Multiple Servers (SSO) in the Session authorization option. 

Step 20 Select LtpaToken in the Set Web SSO Configuration option. 

Step 21 Select Basics and verify that the Load Internet configurations from Server\Internet Sites 
documents field is set to Disabled.

Step 22 Select Save & Close to save your changes. 

Configuring the Domino Server

This section describes how to perform the server-side configuration for the SCOPIA IBM Lotus 
Notes Add-on.

Create a new policy which allows users to run the SCOPIA IBM Lotus Notes Add-on, and then assign 
this policy to user group Notes_Video_conf_sched_group.

Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select the Domain tab displaying the name of your Lotus Domino server.

Step 4 Select the Files tab.

Step 5 Select Databases only in the Show me field. 

Step 6 Double-click ivconfig.nsf in the database list

The iVIEW SCOPIA Management Suite Administrator Settings window displays. Use this window to 
configure the iVIEW SCOPIA Management Suite or SCOPIA Desktops that users can connect to for 
meeting scheduling. 
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Step 7 In the Add Server section:

Set the type of server URL that you want to add in the Server Type field.

Enter a name for the server that you want to add in the Server Name field. 

Enter the server URL in the Server URL field. 

For iVIEW SCOPIA Management Suite use the format http://SERVER_URL:PORT_NUMBER 

For SCOPIA Desktop Server use the format http://SERVER_URL:PORT_NUMBER/scopia 

Step 8 Select Add to list.

Step 9 (Optional) Select Remove from list to remove any defined server from the Select List section.

Step 10 (Optional) Select Check Server Status to verify that the server is reachable. 

The server status is displayed in the Status field. A server must be reachable for the SCOPIA IBM 
Lotus Notes Add-on to function properly. 

Step 11 (Optional) Select Generate LTPA token in the Advanced section to verify that a secure 
communication mechanism has been properly configured between the Lotus Domino server and 
the iVIEW SCOPIA Management Suite server working in Single Sign-on (SSO) mode.

If a new LTPA token is displayed in the Status field, secure communication has been properly 
configured. 

Uninstalling the SCOPIA IBM Lotus Notes Add-on

• Reverting to the Default Mail Template .................................................... page 17

• Removing the ivconfig Database............................................................. page 18

• Removing the mail0_iv Template ............................................................ page 18

Reverting to the Default Mail Template

This procedure uses the following terms where 0 represents the version number of your Lotus 
Domino Server:

• mail0.ntf 

Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select the Domain tab displaying the name of your Lotus Domino server.

Step 4 Select the Server tab.

Step 5 Select the Status tab. 

Step 6 Select Server Console from the list below the Status tab.
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Step 7 Use Domino server console command to change the mail file template for all affected users. 

For example, assume user John’s mail file is John.nsf. Enter the following command in the 
Domino Command field to convert the John.nsf template to mail0.ntf: 

For Windows:>> load convert mail\ John.nsf * mail0.ntf 

For Linux>> load convert mail/ John.nsf * mail0.ntf 

Step 8 To change all mail files in the mail directory, send the following command: 

For Windows:>> load convert mail\*.nsf * mail0.ntf 

For Linux: >> load convert mail/ *.nsf * mail0.ntf 

Removing the ivconfig Database

Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select the Domain tab displaying the name of your Lotus Domino server.

Step 4 Select the Files tab

Step 5 Select Databases Only in the Show me field.

Step 6 Right-click ivconfig.nsf and select Delete Database.

Step 7 Select Also delete replicas of this database on all other servers. 

Step 8 Select OK to delete this database. 

Removing the mail0_iv Template

This procedure uses the following terms where 0 represents the version number of your Lotus 
Domino Server: 

• mail0_IV.ntf 

• Mail (R0) IV 

Procedure

Step 1 Select Start > Programs > Lotus Applications > Lotus Domino Administrator.

Step 2 Sign in using the LocalDomainAdmins account supplied by your Domino Server administrator.

Step 3 Select the Domain tab displaying the name of your Lotus Domino server.

Step 4 Select the Files tab

Step 5 Select All file types in the Show me field.

Step 6 Right-click Mail(RO) IV Addon and select Delete Database.

Step 7 Select Also delete replicas of this database on all other servers. 

Step 8 Select OK to delete this database. 
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