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About This Manual  v

ABOUT THIS MANUAL

The SCOPIA Connector Connector for IBM Lotus Sametime Installation and 
Administration Guide provides information for administrators about SCOPIA 
Connector deployment, and installation in the IBM Lotus Sametime and IBM 
Lotus Sametime Web Conferencing environment.

Note The SCOPIA Connector plug-in works with the following IBM product 
versions:

 Sametime 8.0, 8.0.1, and 8.0.2

 Sametime 8.5

 Lotus Notes 8.0

This manual refers to options available in Sametime 8.0. 

Configuration options may vary according to the product version you are using. 

HOW TO USE THIS 
MANUAL

This manual provides information about deploying both SCOPIA Connector for 
Lotus Sametime and for SCOPIA Connector for Lotus Sametime Web 
Conferencing:

 Chapter 2, Installing the SCOPIA Connector Plug-in for Lotus 
Sametime Connect on page 3

 Chapter 3, Integrating SCOPIA Connector for Lotus Sametime Web 
Conferencing into the Sametime Deployment on page 11



FEEDBACK The team at RADVISION constantly endeavors to provide accurate and 
informative documentation. If you have comments or suggestions regarding 
improvements to future publications, we would value your feedback.

Please send your comments to doc_comments@radvision.com.

We thank you for your contribution.

mailto:doc_comments@radvision.com?subject=Query: SCOPIA Connector version 7.1
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1
PREPARING FOR INSTALLATION

Prior to installing SCOPIA Connector, verify that these conditions are fulfilled:

 IBM Lotus Sametime is configured with Working Sametime 
installation.

 SCOPIA Desktop Server is installed and configured.

 SCOPIA Desktop product CD-ROM is available.
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2
INSTALLING THE SCOPIA CONNECTOR 
PLUG-IN FOR LOTUS SAMETIME 
CONNECT

This section describes how administrators can automatically deploy the 
SCOPIA Connector plug-in throughout a network, and how end users can 
manually install the plug-in on a Sametime Connect client.

 Update Sites on page 3

 Installing the SCOPIA Connector Update Site from the CD-ROM on 
page 4

 How to Install the SCOPIA Connector from an Update Site on page 5

 Distribution Methods for the SCOPIA Connector on page 10

UPDATE SITES An update site is a specific directory layout with an XML file that specifies all 
the available plug-ins. The method of how the update site is presented to the 
client can vary (for example, as a web site or through the local file system).

If SCOPIA Desktop is detected when installing SCOPIA Connector, an Eclipse 
update site is created for you in the SCOPIA Desktop installation directory at   
<installdir>/Tomcat/webapps/ROOT/sametime. You can use the update 
site at this location, or you can copy the files from the update site to a location of 
your choice.

An update site is a specific directory layout with an XML file that specifies all 
the available plug-ins. You can variously present the update site to the client; for 
example, as a web site or via the local file system.
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Installing the SCOPIA Connector Update Site from the CD-ROM

If SCOPIA Desktop is detected when installing SCOPIA Connector, an Eclipse 
update site is created for you in the SCOPIA Desktop installation directory at   
<installdir>/Tomcat/webapps/ROOT/sametime.

We recommend using the installer to create the update site. The update site is 
usually set up on the same server as SCOPIA Desktop.

If you already have plug-ins that you automatically push via an update site, you 
need to merge the SCOPIA Connector site.xml file with the existing site.xml 
file, and copy the contents of the SCOPIA Connector features and plug-ins 
folders into the existing corresponding folders.

INSTALLING THE 
SCOPIA 
CONNECTOR 
UPDATE SITE FROM 
THE CD-ROM

Install the SCOPIA Connector update site from the SCOPIA Desktop 
CD-ROM.

 Procedure

1 Insert the CD-ROM.

2 Wait for the autorun menu screen to display.

3 Select SCOPIA Connector for IBM Lotus Sametime.

4 Select Install Update Site.

5 Select the setup.exe file and follow the on-screen instructions.

The Choose Installation Location screen detects if 
SCOPIA Desktop is installed.

6 If SCOPIA Desktop is detected, the installer attempts to create an 
update site at 

<installdir>/Tomcat/webapps/ROOT/sametime

The default update site URL is http://<server>/sametime.

Where <server> stands for either the IP address or FQDN of the 
server on which you install the SCOPIA Connector.

7 Alternatively, you can configure the installer to create an update site at a 
different location.
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How to Install the SCOPIA Connector from an Update Site

8 If SCOPIA Desktop is not detected, define the location at which you 
want the installer to place the files needed for an update site. 

By default, the installer places the files at

\Program Files\Radvision\SCOPIA Connector for 
IBM Lotus Sametime

You must either place the files needed for an update site under 
a Sametime update site, or distribute them manually.

HOW TO INSTALL 
THE SCOPIA 
CONNECTOR FROM 
AN UPDATE SITE

You can install SCOPIA Connector either automatically or manually.   

 How to Automatically Deploy the SCOPIA Connector on page 5

 Manually Installing the SCOPIA Connector from an Update Site on 
page 7

HOW TO 
AUTOMATICALLY 
DEPLOY THE SCOPIA 
CONNECTOR

 Installing the SCOPIA Connector via the Community Client 
Document (for Administrators) on page 5

 Installing the Plug-in via the preferences.ini File (for End Users) on 
page 6

INSTALLING THE SCOPIA 
CONNECTOR VIA THE 
COMMUNITY CLIENT 
DOCUMENT (FOR 
ADMINISTRATORS)

This section describes how you can automatically deploy the SCOPIA 
Connector plug-in via the Sametime server Community Client Document.

 Procedure

1 Access the SCOPIA Desktop Server.

2 Access the Sametime Server.

3 Double-click the Domino Admin icon on the desktop.

4 Sign in using administrator credentials.

5 Select the Domain tab.

6 Select the Files tab.

7 Double-click the Sametime Configuration (stconfig.nsf) document.

8 Select By Form. 

9 Right-click and select Edit CommunityClient document.

10 Locate the UIM Provisioning field.
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How to Install the SCOPIA Connector from an Update Site

11 Edit the URL in the field by adding the full path to your update site 
(including http://). For example, http://<server name or IP>/sametime.

12 Copy this URL to the Sametime update site URL field in the Policy 
which applies to the users:

a Using the web-based server administrator 
(http://<sametime server>/stcenter.nsf) sign in as the administrator.

b Where <server> stands for either the IP address or FQDN of the 
Sametime Server.

c Select the Administer the server link.

d Select the Policies link.

e Select the Sametime Default Policy link.

f Scroll down to the Instant Messaging section.

g Modify the Sametime update site URL with local update site on the 
Sametime server.

h Check the Override all policies check box to immediately push the 
new configuration to clients.

i Select OK to save your changes.

j Use another web page and run the Domino Server Administrator 
(http://<server>/webadmin.nsf).

k Sign in and select the Server tab at the top of the page.

l Select Tools > Server > Restart to restart your Sametime server. 

The next time a user signs in to the Sametime Connect client, 
the plug-in is downloaded and the user is prompted to restart the 
Sametime client.

13 Save and close the stconfig.nsf file.

INSTALLING THE PLUG-IN 
VIA THE PREFERENCES.INI 
FILE (FOR END USERS)

This section describes how you can automatically deploy the SCOPIA 
Connector plug-in via the Sametime Connect preferences.ini configuration file.

The preferences.ini file is located by default at the following locations on the 
Sametime Connect client:

 Sametime 7.5.x

C:\Program Files\ibm\Sametime Connect\plugins\

com.ibm.collaboration.realtime.update_1.0.0
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How to Install the SCOPIA Connector from an Update Site

 Sametime 8.0

C:\Program Files\IBM\Lotus\Sametime 
Connect\shared\

eclipse\plugins\com.ibm.collaboration.realtime
.update_8.0.0.20071119-1552

 Procedure

1 Access the SCOPIA Desktop Server.

2 Create an update site (see How to Install the SCOPIA Connector from 
an Update Site on page 5 for an explanation of update sites).

3 Open the preferences.ini file. 

4 Enter your update site URL as the value for the adminUpdatePolicyURL 
parameter. Use the format

adminUpdatePolicyURL=http://server.domain.com/

sametime/site.xml

5 Save and close the preferences.ini file.

The next time the user signs in to the Sametime Connect client, 
the client searches for the update site URL in the URL for UIM 
Provisioning parameter of the stconfig.nsf file on the Sametime 
server.

If the client fails to find the URL, the client searches for the 
value of the adminUpdatePolicyURL parameter of the 
preferences.ini file.

When the client finds this value, the plug-in is downloaded and 
the user is prompted to restart the Sametime client.

MANUALLY INSTALLING 
THE SCOPIA 
CONNECTOR FROM AN 
UPDATE SITE

This section describes how Sametime users can manually install the SCOPIA 
Connector plug-in on a Sametime Connect client.

The SCOPIA Connector plug-in is available for download from an update site. 
For more information, see How to Install the SCOPIA Connector from an 
Update Site on page 5.

Note Sametime Administrators may prevent users from performing manual 
downloads. For more information, see Preventing Manual Downloading on 
page 9. 
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How to Install the SCOPIA Connector from an Update Site

 Procedure

1 In the Sametime Connect client user interface, choose 

 (for Sametime 7.5 CF1) File > Manage Updates > 
Download Plugins 

 (for Sametime 7.5.1 and 8.0) Tools > Plug-ins > 
Install plug-ins.

2 If you have a previous version of the plug-in already installed, the 
installer prompts you to search for updates to the currently installed 
features. In the Feature Updates window, choose Search for updates of 
the currently installed features, and then go to step 9.

3 If you do not have a previous version of the plug-in installed, in the 
Feature Updates window choose Search for new features to install, 
and select Next.

4 In the Update sites to visit window, select Add Remote Location (or 
New Remote Site for Sametime 7.5.1 CF1).

5 Enter an update site name and URL.

For example, name “SCOPIA Connector” and URL 
http://<server>/sametime.

Where <server> stands for either the IP address or FQDN of the 
server hosting the update site.

6 Select OK to save the location.

7 Check the checkbox for the new location.

8 Select Finish.

9 In the Search Results window, expand the tree labeled with the name 
that you entered at step 5 to view all available
SCOPIA Connector plug-ins.

10 Choose the latest version of the SCOPIA Connector plug-in and click 
Next.

11 In the Feature License window, accept the terms of the license 
agreement and select Next.
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How to Install the SCOPIA Connector from an Update Site

12 In the Installation window, select Finish.

If the installation is successful, you are prompted to restart the 
Sametime client to access to the new plug-ins.

Installation is now complete and the SCOPIA Connector 
plug-in Preferences window is now available.

PREVENTING MANUAL 
DOWNLOADING

This section describes how Sametime administrators can prevent users from 
performing manual downloads to a Sametime Connect client.

 Procedure

1 On the Sametime server host machine, open the sametime.ini 
configuration file located at \Lotus\Domino. 

2 Under the [config] section, add the following line: 
DisableConnectPluginUpdates=1. 

3 Restart the server and reconnect with the client. 

The user options are grayed out.

In the Sametime Connect client user interface, the options under 
Tools > Plug-ins are disabled.

INSTALLING THE 
SCOPIA CONNECTOR 
WITHOUT AN HTTP 
SERVER

This section describes how to install the SCOPIA Connector plug-in in 
Sametime Connect client from a local file without using an HTTP server. To do 
this, you locate the update site in a shared network directory. Users can then 
access this directory from the Sametime Client interface.

 Procedure

1 Save the sametime directory to a shared network location.

2 In the Sametime Connect client user interface, choose Tools > Plug-ins 
> Install plug-ins.

3 In the Feature Updates window choose Search for new features to 
install, and select Next.

4 In the Update sites to visit window, select Add Folder Location (for 
Sametime 8.0) or New Local Site (for Sametime 7.5.1), navigate to the 
saved sametime directory and select OK.
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Distribution Methods for the SCOPIA Connector

5 Select Finish. The Sametime Connect client now searches for updates 
from the defined site.

6 In the Search Results window, select sametime. 

7 Enter a new name for the directory and select OK, or leave the directory 
name unchanged.

8 Select Next.

9 In the Feature License window, accept the terms of the license 
agreement and select Next.

10 In the Installation window, select Finish.

11 Select Install or Install All.

If the installation is successful, you are prompted to restart the 
Sametime client to access to the new plug-ins.

Installation is now complete and the SCOPIA Connector 
plug-in Preferences window is now available.

DISTRIBUTION 
METHODS FOR THE 
SCOPIA 
CONNECTOR

You can distribute the SCOPIA Connector plug-in by using these methods: 

 “Pushing” the plug-in to all Lotus Sametime Connect users in a 
specified community.

The plug-in is automatically downloaded to the client when the 
user launches Lotus Sametime Connect. The user is notified of 
the update and can choose to automatically restart the client to 
load the new plug-in.

For more information, see How to Automatically Deploy the 
SCOPIA Connector on page 5.

 Sending the update site URL to users:

Users must retrieve and install the plug-in manually using the 
Lotus Sametime Connect Manage Updates user interface.

For more information, see Manually Installing the SCOPIA 
Connector from an Update Site on page 7.

You can optionally prevent users from performing this 
procedure. For more information, see Preventing Manual 
Downloading on page 9.
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3
INTEGRATING SCOPIA CONNECTOR 
FOR LOTUS SAMETIME WEB 
CONFERENCING INTO THE SAMETIME 
DEPLOYMENT

 About Deploying IBM Lotus Sametime Web Conferencing with 
SCOPIA Connector Deployment on page 11

 Installing the Sametime Connector on the SCOPIA Desktop Server 
on page 15

 How to Prepare the Sametime Servers on page 15

 Configuring the Sametime Settings on the SCOPIA Desktop Server 
on page 16

ABOUT DEPLOYING 
IBM LOTUS 
SAMETIME WEB 
CONFERENCING 
WITH SCOPIA 
CONNECTOR 
DEPLOYMENT

When you integrate IBM Lotus Sametime with SCOPIA Desktop, your users 
can add real-time multipoint video and audio to Sametime Web meetings. To 
accomplish this, you must associate a SCOPIA Desktop Server with an IBM 
Lotus Sametime Community deployment.

You use two modules for the integration:

 Sametime Connector, a Sametime Community Server application 
that runs as part of the SCOPIA Desktop middleware

 Sametime Meeting Room Client Javascript extension that is used to 
realize the user interface inside the Sametime Meeting Room Client
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About Deploying IBM Lotus Sametime Web Conferencing with SCOPIA Connector Deployment

Sametime Connector detects the start of a Sametime meeting and attaches 
meeting attributes along with an ID of a SCOPIA Desktop ad-hoc meeting 
which is generated at that time. The Javascript extension is loaded with the 
Meeting Room Client when a user joins a Sametime meeting and pulls the video 
meeting information from the meeting so that all attendees transparently join the 
same video meeting.

Read these sections to correctly plan your deployment:

 Simple Sametime Deployments on page 12

 Multiple Sametime Community Hubs Deployments on page 13

SIMPLE SAMETIME 
DEPLOYMENTS

Use this diagram when planning your Sametime Deployment.

Figure 3-1 Simple Sametime Deployment
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About Deploying IBM Lotus Sametime Web Conferencing with SCOPIA Connector Deployment

MULTIPLE SAMETIME 
COMMUNITY HUBS 
DEPLOYMENTS

In deployments described in this section, there may be multiple community 
hubs. Users schedule meetings through their home Sametime Server and may 
invite users from the same home server as well as users from other Community 
Server clusters. The meetings may be hosted on the home Sametime Server of 
the meeting creator as shown on Figure 3-2. In this case, meeting attributes do 
not need to be propagated to the other server. 

Figure 3-2 Multiple Sametime Community Hub Deployment for 
non-propagated meetings

SCOPIA Desktop with
Community Server App Sametime

Sametime MR Client

Location A

SCOPIA Desktop with
Community Server AppSametime

Sametime MR Client

Location B

2. New Meeting
Event

1. MR Client starts 
new meeting and 

joins it.

5. Java script
extension plug-in 
provides video.

3. Set activity 
attribute URL.

4. MR Client 
receives video URL 

attributes.

8. Javascript
extension plug-in 
provides video.

7. MR Client 
receives video URL 

attributes.

6. MR Client joins 
Sametime meeting.



14 SCOPIA Connector for IBM Lotus Sametime Installation and Administration Guide

About Deploying IBM Lotus Sametime Web Conferencing with SCOPIA Connector Deployment

Alternatively, meetings may be hosted on different Sametime Servers. In this 
case, the meeting information and attributes are propagated from the home 
Sametime Server to the other server as shown on Figure 3-3 on page 14.

Figure 3-3 Multiple Sametime Community Hub Deployment for 
propagated meetings
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Installing the Sametime Connector on the SCOPIA Desktop Server

INSTALLING THE 
SAMETIME 
CONNECTOR ON 
THE 
SCOPIA DESKTOP 
SERVER

 Procedure

1 On the SCOPIA Desktop Server, navigate to this location: 
>InstallDir>SCOPIA Desktop\SametimeWeb.

2 Double-click the enable_sametime.vbs file.

3 Select OK in the confirmation message.

When the installation is completed, a message is displayed 
explaining that the Sametime Connector is installed and the log 
file is created.

HOW TO PREPARE 
THE SAMETIME 
SERVERS

 Enabling Community Services Connectivity on page 15

 Installing the Meeting Room Client Javascript Extension on page 16

ENABLING COMMUNITY 
SERVICES 
CONNECTIVITY

To prepare the Sametime server for the SCOPIA Connector for IBM Lotus 
Sametime Web Conferencing, you must edit the Sametime configuration: open 
the IBM Domino Administrator Application and change the IP address 
configuration of the SCOPIA Desktop Server to allow connection to 
Community Services. Perform this procedure on every Sametime server that has 
a SCOPIA Desktop Server associated with it.

 Procedure

1 Open the IBM Domino Administrator application.

2 Select the Domain tab.

3 Select the Files tab.

4 Navigate to this location: \Program Files\IBM\Lotus\Domino\Data.

5 Double-click the Sametime Configuration file.

6 Select By Form in the left pane.
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Configuring the Sametime Settings on the SCOPIA Desktop Server

7 Right-click the CommunityConnectivity, and then select Edit.

The form opens.

8 Enter the IP address of the SCOPIA Desktop Server in the Community 
Trusted IPS field.

9 Select File > Save.

INSTALLING THE 
MEETING ROOM 
CLIENT JAVASCRIPT 
EXTENSION

To enable the video integration, you need to copy a file to the Sametime server. 
This file was placed on the SCOPIA Desktop Server during the SCOPIA 
Connector installation.

 Procedure

1 On the SCOPIA Desktop Server, navigate to this location:

Program Files\Radvision\SCOPIA Desktop\SametimeWeb\

2 Copy the SDMrcExtension.js file.

3 On the Sametime server, create this location:

\Program 
Files\IBM\Lotus\Domino\data\domino\html\sametime\jsext

4 Paste the copied file into this location.

CONFIGURING THE 
SAMETIME 
SETTINGS ON THE 
SCOPIA DESKTOP 
SERVER

You need to configure the SCOPIA Desktop Server to work with the Sametime 
Server.

By default, the SCOPIA Desktop Server generates meeting IDs for IBM Lotus 
Sametime Web Conferencing meetings dynamically. The SCOPIA Desktop 
Server uses a service number configured in SCOPIA MCU as a meeting prefix, 
adding a randomly generated four-digit number to it to create a meeting ID. In 
deployments using iVIEW Suite, you can configure the SCOPIA Desktop 
Server to use a predefined virtual room.

Before You Begin

 Access the SCOPIA Desktop Administration web user interface.

 Verify the Sametime Server address.
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Configuring the Sametime Settings on the SCOPIA Desktop Server

 Verify which port on the Sametime Server you need to assign to the 
SCOPIA Desktop Server.

 If you want to set the meeting prefix, access the iVIEW Suite 
Administration web pages, navigate to Network Tree > 
required MCU > Services, and verify what services are 
available.

 Procedure

1 Select Sametime in the sidebar.

2 Enter the Sametime Server address.

3 Enter the port on the Sametime Server.

The default port is 1516.

4 For deployments using SCOPIA MCU, select Generate meeting IDs 
dynamically, using the specified meeting prefix, and then enter the 
meeting prefix. The meeting ID generated by SCOPIA Desktop Server 
will be based on the meeting prefix you define.

-or-

5 For deployments using iVIEW Suite, select Use the meeting creator’s 
virtual room. The virtual room configured for this user on iVIEW Suite 
will be used.

6 Enter the meeting prefix for the SCOPIA Desktop Server to use for the 
Sametime meetings.

7 If necessary, set the number of video panes displayed in the Conference 
Client pane when it is opened in the Sametime Meeting Room window:

a Select Set the initial view that users will see when 
they join a Sametime meeting.

b Select one of these options:

 1 Video

 2 Videos

8 If necessary, select Enable Audio in SCOPIA Desktop for Sametime 
meetings.
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Configuring the Sametime Settings on the SCOPIA Desktop Server

9 If necessary, select Allow only the Sametime Meeting Chair to add 
video to a meeting. This allows a Sametime Meeting chair to control 
when the video pane is displayed in the user's meeting room client.

Note This feature in not available if the SCOPIA Connector is configured to 
work with the Sametime Server version 7.5.1.

10 If necessary, select Allow only the Sametime Meeting Chair to 
moderate a meeting. This determines whether audio and video 
moderation functions are enabled only a Sametime Meeting chair or for 
all participants in a SCOPIA Desktop meeting.

11 Select OK or Apply.

12 Verify that the connection to the Sametime Server is successful:

a Select Status in the sidebar.

b Select the link showing the IP address of the Sametime 
Server to display the settings.

The indicator next to the link shows whether or not the 
connection to the Sametime server is successful. When the 
indicator is red, a tooltip containing error details is 
available. Select the red indicator to view further error 
information.
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