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ABOUT THIS MANUAL

The SCOPIA IBM Lotus Notes Add-on Deployment Guide provides 
information on deploying the SCOPIA IBM Lotus Notes Add-on.

RELATED 
DOCUMENTATION

Documentation is available on the RADVISION Utilities and Documentation 
CD-ROM supplied with the product and includes manuals and online helps. The 
manuals are in PDF format.

Note You require Adobe Acrobat Reader version 6.0 or later to open the PDF 
files. You can download Acrobat Reader free of charge from www.adobe.com. 

CONVENTIONS 
USED IN THIS 
MANUAL

SCOPIA IBM Lotus Notes Add-on is sometimes referred to as “the add-on” 
throughout this manual. 

FEEDBACK The team at RADVISION constantly endeavors to provide accurate and 
informative documentation. If you have comments or suggestions regarding 
improvements to future publications, we would value your feedback.
Please send your comments to doc_comments@radvision.com.
We thank you for your contribution.

http:\\www.adobe.com
mailto:doc_comments@radvision.com?subject=Query: iVIEW Suite v7.1 SCOPIA IBM Lotus Notes Add-on Deployment Guide
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DEPLOYING THE SCOPIA IBM LOTUS 
NOTES ADD-ON

� Overview on page 1
� Lotus Domino User Interface on page 2
� Prerequisites on page 2
� How to Verify that the DIIOP and HTTP Services are Running on page 3
� How to Install the SCOPIA IBM Lotus Notes Add-on on page 4
� How to Configure the SCOPIA IBM Lotus Notes Add-on on page 13
� Configuring the Domino Server on page 18
� How to Uninstall the SCOPIA IBM Lotus Notes Add-on on page 19

OVERVIEW The SCOPIA IBM Lotus Notes Add-on is a separately deployed plug-in that can 
work in a iVIEW Suite deployment or in a standalone SCOPIA Desktop 
deployment without iVIEW Suite.
In an iVIEW Suite deployment, the IBM Lotus Notes Add-on allows users to 
schedule, modify, cancel and manage iCM meetings using the IBM Lotus Notes 
interface.
In a standalone SCOPIA Desktop deployment, the SCOPIA IBM Lotus Notes 
Add-on allows users to send out meeting invitations using the IBM Lotus Notes 
interface.
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LOTUS DOMINO 
USER INTERFACE

This document uses the Lotus Domino 8 interface to illustrate procedures. There 
are several minor differences between the user interfaces for each of the 
supported Lotus Domino versions, including the following:

� Version 7.0 includes a File > Database option. This is replaced in version 
8 by File > Application.

� Version 7 includes a Server list in the Open Database dialog box. This is 
replaced in version 8 by the Look in option.

PREREQUISITES

SYSTEM 
REQUIREMENTS

Lotus Domino Server
� Supported versions: 7.0, 8.0 and 8.5
� Running DIIOP HTTP services
� Configured with LTPA token
� Lotus Domino Administrator and Designer interfaces must be available

Each user should have a dedicated email account for receiving meeting messages 
including meeting accept and decline messages.
For iVIEW Suite deployments

� A dedicated iVIEW Suite server which the IBM Lotus Notes Add-on can 
connect to.

� This iVIEW Suite server should be configured to work with IBM 
Domino server LDAP Directory service.

� Assign at least one virtual room to each user.
For SCOPIA Desktop deployments

� A dedicated SCOPIA Desktop server which the IBM Lotus Notes 
Add-on can connect to.

INSTALLATION FILES The following files are provided with the product:
� Setup0.nsf (where 0 represents the version number of your Lotus 

Domino Server) containing the agents used to install or upgrade SCOPIA 
IBM Lotus Notes Add-on.

� 9 .dxl files containing the code used to install SCOPIA IBM Lotus Notes 
Add-on
� IVAgentLib.dxl
� IVClientConfig.dxl
� IVConfig.dxl
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� IVForm.dxl
� IVShareLib.dxl
� IVSubForm.dxl
� LotusAddonAppletJar.dxl
� MeetingAgent.dxl
� SDAccessAgent.dxl

Copy them all to a location of your choice on your computer.

HOW TO VERIFY 
THAT THE DIIOP 
AND HTTP 
SERVICES ARE 
RUNNING

 ) Procedure

 1 Use a text editing application to open the notes.ini file located at 
C:\Program Files\IBM\Lotus\Domino\ on your computer. 

 2 Locate the line 
ServerTasks=Update,Replica,Router,AMgr,AdminP,CalConn
,Sched,LDAP,RnRMgr,DIIOP,HTTP

 3 Verify that DIIOP and HTTP are present. Add them if they are not.
 4 Restart your Domino server.
 5 Select Start > Programs > Lotus Applications > Lotus Domino 

Administrator.
 6 Sign in using the LocalDomainAdmins account supplied by your 

Domino Server administrator.
 7 Select the Domain tab displaying the name of your Lotus Domino 

server.
 8 Select the Server tab.
 9 Select the Status tab.

 10 Select Server Tasks from the list below the Status tab.
 11 Verify that the DIIOP Server and HTTP Server tasks appear. 
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HOW TO INSTALL 
THE SCOPIA IBM 
LOTUS NOTES 
ADD-ON

� Creating NSF Objects in the Domino Designer Interface on page 5
� Configuring a Template in the Domino Administrator Interface on page 6
� Configuring Forms and Script Libraries in the Domino Designer 

Interface on page 9
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CREATING NSF 
OBJECTS IN THE 
DOMINO DESIGNER 
INTERFACE

This procedure uses the following terms where 0 represents the version number 
of your Lotus Domino Server:

� mail0.ntf
� mail0_IV.ntf

 ) Procedure

 1 Select Start > Programs > Lotus Applications > Lotus Domino 
Designer to connect to the target Domino server.

 2 Sign in using the LocalDomainAdmins account supplied by your 
Domino Server administrator.

 3 Select File > Application > Open in the Lotus Domino Designer 
interface.

 4 Browse to the setup.nsf file and select Open.
 5 Select the setup icon in the left panel to expand it.
 6 Select Shared Code > Agents.
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 7 Sign the agents as follows:
a Select the Create IVConfig.nsf agent in the panel on the right, and 

then select the Sign button.
Create IVConfig.nsf contains the SCOPIA IBM Lotus Notes 
Add-on configuration screen.

b Select the Create mail0_IV.ntf agent in the panel on the right, and 
then select the Sign button.
Create mail0_IV.ntf contains a new template file for scheduling 
meetings using the SCOPIA IBM Lotus Notes Add-on, based on 
mail0.ntf.

c Create the IVConfig.nsf file on the Domino server as follows:
 8 Right-click the Create IVConfig.nsf agent and select Run.
 9 Select File > Application > Open and browse to the IVConfig.dxl file.

 10 Select Open.
 11 Create the mail0_IV.ntf file on the remote server as follows:

a Right-click the Create mail0_IV.ntf agent and select Run.
b Select File > Application > Open and browse to the 

IVAgentLib.dxl file.
c Select Open.

 12 Close the Domino Designer interface.

CONFIGURING A 
TEMPLATE IN THE 
DOMINO 
ADMINISTRATOR 
INTERFACE

This procedure uses the following terms where 0 represents the version number 
of your Lotus Domino Server:

� mail0_IV.ntf
� Stdmail0_IV

 ) Procedure

 1 Select Start > Programs > Lotus Applications > Lotus Domino 
Administrator.

 2 Sign in using the LocalDomainAdmins account supplied by your 
Domino Server administrator.

 3 Select the Domain tab displaying the name of your Lotus Domino 
server.
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 4 Select the Files tab.
 5 Select All file types in the Show me field.
 6 Locate the mail0_IV.ntf file in the filename list.
 7 Right-click mail0_IV.ntf and select Properties to display the Database 

dialog box.

 8 Select the Design tab (the fourth tab from the left).
 9 Select Database file is master template.

 10 Enter StdMail0_IV in the Template Name field.
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 11 Close the Database dialog box.
 12 Save your changes.
 13 Close the Domino Administrator interface.
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CONFIGURING 
FORMS AND SCRIPT 
LIBRARIES IN THE 
DOMINO DESIGNER 
INTERFACE

This procedure uses the following terms where 0 represents the version number 
of your Lotus Domino Server:

� Mail (R0) IV

 ) Procedure

 1 Select Start > Programs > Lotus Applications > Lotus Domino 
Designer to connect to the target Domino server.

 2 Sign in using the LocalDomainAdmins account supplied by your 
Domino Server administrator.

 3 Select File > Application > Open in the Lotus Domino Designer 
interface.

 4 Select the Look in drop-down list.
 5 Select the remote Domino server that has the SCOPIA IBM Lotus Notes 

Add-on installed from the list.
 6 Select Mail (R0) IV Addon from the database list, and then select 

Open.
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 7 Double-click _Calender Entry in the list of forms that displays.
 8 Scroll to the end of the code that appears above the list of forms and 

locate the Body field.

 9 Place your cursor next to the Body field and then select Create > 
Resource > Insert Subform from the menu at the top of the screen.

 10 Select IVSubForm from the Insert Subform window.
 11 Select OK and verify that the subform is inserted near the Body field.

 12 Select the X in the _Calendar Entry Form tab to save and close the 
_Calendar Entry form.

 13 Select View > Go to > Views from the menu at the top of the screen to 
display all views in the Mail (R0) IV Addon database.

 14 Double-click ($Calendar).
 15 Select View again from the menu at the top of the screen and verify that 

Action Pane is selected.
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 16 Locate the Action pane at the right of the screen.
 17 Right-click Unfilter and select Create Action.

 18 Enter SCOPIA Settings in the Name field in the first tab of the Actions 
dialog box.

 19 Select Hide action if formula is true in the second tab of the Action 
dialog box, and select Formula Window.

 20 Paste the following code in the Edit Formula window:
@If(@TextToNumber(@Version) < 174;@True;@False) | 
@Environment("OEMClient") = "1" | 
@IsNotMember("Notes_Video_conf_sched_group"; 
@UserNamesList)

 21 Select Done to close the Action window.
 22 Paste the following code in the (Action): Click window:

@If(@ClientType = 
"Notes";@Command([Compose];"IVClientConfig") : 
@Return(0);"")

 23 Select the Mail (R0) IV Addon tab.
 24 Select View > Go to > Forms from the menu at the top of the screen.
 25 Double-click _Calender Entry in the list of forms that displays.
 26 Select View again from the menu at the top of the screen and verify that 

Programmer’s Pane is selected.
 27 Select (Globals)Appointment > (Options) in the Objects tab and add 

the following line at the end of the code:
Use "IVShareLib"
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 28 Select Appointment (Form) > Queryopen in the Objects tab.
 29 Locate CSCalendarEntry in the code and replace with IVCSWrapper.

 30 Save and close the form.
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 31 Enter code into the CSUIViewClass Script Library as follows:
a Select the Mail (R0) IV Addon tab.
b Select View > Go to > Script Libraries from the menu at the top of 

the screen to display all script libraries for the Mail (R0) IV Addon 
database.

c Double-click CSUIViewClass.
d Select CSUIView > (Options) in the Objects tab and add the 

following line at the end of the code:
Use "IVShareLib"

e Select CSUIView > InitEventObject in the Objects tab. 
f Locate CSEventNotes in the code and replace with 

IVCalendarWrapper.
g Save and close the script library.

HOW TO 
CONFIGURE THE 
SCOPIA IBM 
LOTUS NOTES 
ADD-ON

� Using a New Template on page 13
� Configuring Domino Web Single Sign-on on page 15
� Assigning an Execution Control List on page 16

USING A NEW 
TEMPLATE

This procedure uses the following terms where 0 represents the version number 
of your Lotus Domino Server:

� mail0_IV.ntf

 ) Procedure

 1 Select Start > Programs > Lotus Applications > Lotus Domino 
Administrator.

 2 Sign in using the LocalDomainAdmins account supplied by your 
Domino Server administrator.

 3 Select the Domain tab displaying the name of your Lotus Domino 
server.

 4 Select the People & Groups tab, and then select Add Group.
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 5 Create a user group called Notes_Video_conf_sched_group.
Any user that you assign to this group can see the user interface of the 
SCOPIA IBM Lotus Notes Add-on.

 6 Access the Domino server console as follows:
a Select Start > Programs > Lotus Applications > Lotus Domino 

Administrator.
b Sign in using the LocalDomainAdmins account supplied by your 

Domino Server administrator.
c Select the Domain tab displaying the name of your Lotus Domino 

server.
d Select the Server tab.
e Select the Status tab.
f Select Server Console from the list below the Status tab.

 7 Use the Domino server console command to change the mail file 
template for all affected users.
For example, assume user John’s mail file is John.nsf. Enter the 
following command in the Domino Command field to convert the 
John.nsf template to mail0_IV.ntf:
For Windows:
>> load convert mail\ John.nsf * mail0_IV.ntf

For Linux
>> load convert mail/ John.nsf * mail0_IV.ntf 

 8 To change all mail files in the mail directory, send the following 
command:
For Windows:
>> load convert mail\*.nsf * mail0_IV.ntf

For Linux: 
>> load convert mail/ *.nsf * mail0_IV.ntf
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CONFIGURING 
DOMINO WEB SINGLE 
SIGN-ON 

The Web Single Sign-on (SSO) configuration described here is R5 compatible.

 ) Procedure

 1 Select Start > Programs > Lotus Applications > Lotus Domino 
Administrator.

 2 Sign in using the LocalDomainAdmins account supplied by your 
Domino Server administrator.

 3 Select the Domain tab displaying the name of your Lotus Domino 
server.

 4 Select the Configuration tab.
 5 Select Server > Current Server Document. 
 6 Select Create Web and then SSO Configuration.

 7 Enter the iVIEW Suite server DNS domain in the DNS Domain field.
For example, “mycompany.com”.

 8 Select the arrow next to the Domino Server Names field to display the 
Select Name dialog box.

 9 Select the name of the Domino server with the SCOPIA IBM Lotus 
Notes Add-on installed from the list in the left panel, and move it to the 
Names list in the right panel.
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 10 Select OK to close the Select Name dialog box.
 11 Verify that the name of the Domino server with the SCOPIA IBM Lotus 

Notes Add-on installed appears in the Domino Server Names field.
 12 Select Keys > Create Domino SSO Key to generate a new key.
 13 Select Save & Close to save your changes and close the Web SSO 

Configuration window.
 14 Select the Configuration tab.
 15 Select Server > Current Server Document. 
 16 Select Internet Protocols > Domino Web Engine.
 17 Select Edit Server.
 18 Select Multiple Servers (SSO) in the Session authorization option.
 19 Select LtpaToken in the Set Web SSO Configuration option.
 20 Select Basics and verify that the Load Internet configurations from 

Server\Internet Sites documents field is set to Disabled.
 21 Select Save & Close to save your changes.

ASSIGNING AN 
EXECUTION 
CONTROL LIST

Assign an Execution Control List (ECL) to users so that they can execute the 
SCOPIA IBM Lotus Notes Add-on client-side module.
Create a new policy which allows users to run the SCOPIA IBM Lotus Notes 
Add-on, and then assign this policy to user group 
Notes_Video_conf_sched_group.

 ) Procedure

 1 Select Start > Programs > Lotus Applications > Lotus Domino 
Administrator.

 2 Sign in using the LocalDomainAdmins account supplied by your 
Domino Server administrator.

 3 Select the Domain tab displaying the name of your Lotus Domino 
server.

 4 Select the Configuration tab.
 5 Select Policies > Create in the right panel to create a new policy. 
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 6 Select the Policy option in the Create New Policy dialog box and select 
OK.

 7 Select Basics and enter a name for the policy in the Policy name field 
such as “IV_POLICY”.

 8 Select New next to the Security field to create new security settings.
 9 Enter a name for the new security setting in the Basics tab such as 

“IV_SECURITY”.
 10 Select Execution Control List.
 11 Select Refresh in the Set Update Mode field.
 12 Select Manage next to Admin ECL and enter a name for the ECL in the 

Create New Admin ECL field such as “IV_ECL”.
 13 Select OK and then Edit.
 14 Select Allow user to modify and Workstation security in the 

Workstation Security: Execution Control List dialog box.
 15 Select Add and then select the icon in the Add User dialog box to 

specify the users that have permission to modify workstation security.   
 16 Select Java applet security in the Workstation Security: Execution 

Control List dialog box and repeat 15.
 17 Select the following access options:

� Access to file system
� Access to Notes Java classes
� Access to network addresses
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� Printing
� Access to system properties
� Dialog and clipboard access
� Process-level access

 18 Select OK to save your changes and close the Execution Control List 
window.

 19 Verify that IV_POLICY appears in the Configuration tab. 
 20 Select the People & Groups tab and select Groups.
 21 Right-click Notes_Video_conf_sched_group and select Assign Policy. 
 22 Select IV_POLICY for this user group.
 23 Select OK to save your changes.

CONFIGURING THE 
DOMINO SERVER

This section describes how to perform the server-side configuration for the 
SCOPIA IBM Lotus Notes Add-on. 

 ) Procedure

 1 Select Start > Programs > Lotus Applications > Lotus Domino 
Administrator.

 2 Sign in using the LocalDomainAdmins account supplied by your 
Domino Server administrator.

 3 Select the Domain tab displaying the name of your Lotus Domino 
server.

 4 Select the Files tab.
 5 Select Databases only in the Show me field.
 6 Double-click ivconfig.nsf in the database list.

The iVIEW Administrator Settings window displays. Use this window to 
configure the iVIEW Suite or SCOPIA Desktops that users can connect 
to for meeting scheduling. 
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 7 In the Add Server section
Set the type of server URL that you want to add in the Server Type field.
Enter a name for the server that you want to add in the Server Name field.
Enter the server URL in the Server URL field. 
For iVIEW Suite use the format 
http://SERVER_URL:PORT_NUMBER
For SCOPIA Desktop Server use the format 
http://SERVER_URL:PORT_NUMBER/scopia

 8 Select Add to list.
 9 (Optional) Select Remove from list to remove any defined server from 

the Select List section.
 10 (Optional) Select Check Server Status to verify that the server is 

reachable.
The server status is displayed in the Status field. 
A server must be reachable for the SCOPIA IBM Lotus Notes Add-on to 
function properly.

 11 (Optional) Select Generate LTPA token in the Advanced section to 
verify that a secure communication mechanism has been properly 
configured between the Lotus Domino server and the iVIEW Suite 
server working in Single Sign-on (SSO) mode.
If a new LTPA token is displayed in the Status field, secure 
communication has been properly configured.

HOW TO UNINSTALL 
THE SCOPIA IBM 
LOTUS NOTES 
ADD-ON

� Reverting to the Default Mail Template on page 20
� Removing the ivconfig Database on page 21
� Removing the mail0_iv Template on page 21
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REVERTING TO THE 
DEFAULT MAIL 
TEMPLATE

This procedure uses the following terms where 0 represents the version number 
of your Lotus Domino Server:

� mail0.ntf

 ) Procedure

 1 Access the Domino server console as follows:
a Select Start > Programs > Lotus Applications > Lotus Domino 

Administrator.
b Sign in using the LocalDomainAdmins account supplied by your 

Domino Server administrator.
c Select the Domain tab displaying the name of your Lotus Domino 

server.
d Select the Server tab.
e Select the Status tab.
f Select Server Console from the list below the Status tab.

 2 Use Domino server console command to change the mail file template 
for all affected users.
For example, assume user John’s mail file is John.nsf. Enter the 
following command in the Domino Command field to convert the 
John.nsf template to mail0.ntf:
For Windows:
>> load convert mail\ John.nsf * mail0.ntf

For Linux
>> load convert mail/ John.nsf * mail0.ntf

 3 To change all mail files in the mail directory, send the following 
command:
For Windows:
>> load convert mail\*.nsf * mail0.ntf

For Linux: 
>> load convert mail/ *.nsf * mail0.ntf
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REMOVING THE 
IVCONFIG DATABASE

 ) Procedure

 1 Select Start > Programs > Lotus Applications > Lotus Domino 
Administrator.

 2 Sign in using the LocalDomainAdmins account supplied by your 
Domino Server administrator.

 3 Select the Domain tab displaying the name of your Lotus Domino 
server.

 4 Select the Files tab.
 5 Select Databases only in the Show me field.
 6 Right-click ivconfig.nsf and select Delete Database.
 7 Select Also delete replicas of this database on all other servers.
 8 Select OK to delete this database.

REMOVING THE 
MAIL0_IV TEMPLATE 

This procedure uses the following terms where 0 represents the version number 
of your Lotus Domino Server:

� mail0_IV.ntf
� Mail (R0) IV

 ) Procedure

 1 Select Start > Programs > Lotus Applications > Lotus Domino 
Administrator.

 2 Sign in using the LocalDomainAdmins account supplied by your 
Domino Server administrator.

 3 Select the Domain tab displaying the name of your Lotus Domino 
server.

 4 Select the Files tab.
 5 Select All file types in the Show me field.
 6 Right-click Mail (R0) IV Addon and select Delete Database.
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 7 Select Also delete replicas of this database on all other servers.
 8 Select OK to delete this template.
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